Veriff works best with the following browsers:

Support for other browsers is in development and it is not recommended to start your verification attempt with Edge, Internet Explorer or any native browser.

It is also highly recommended to update your browser as using outdated browser versions might give unexpected results.

While there are no restrictions to devices used for the verification, there are limitations for which version of the operating system can be used. Updating the operating system on your device is highly recommended.

Supported mobile OS versions:

  • Android 4.4 KitKat and above
  • iOs 11 and above
Did this answer your question?